4
Vote

Package Load Failure

description

The environment is Windows Server 2008 X64 Edition, Visual Studio 2008 Team Developer Edition SP1. A fresh install, no unnecessary Packages/Software, all Service Packs.
 
The Installer runs, it also exits without any UI (e.g. no confirmation of success). I don't know if this is intentional.
 
Launching VS produces no problem, however, upon loading a pre-existing C# project I get a VSPackage Load Failure dialog, and I've opted to skip this package during load.
 
Is this a known issue?

comments

the_skipster wrote Aug 17, 2009 at 5:44 PM

This would be amazing if I could get it to work. I get the same error as discussed here and in the forums. I tried to download and run the source, but there are a whole bunch of dependencies that are not listed anywhere. Can you please list what you have installed in your dev environment so we can run/debug your code, and, perhaps, point you in the right direction of the error?

Thanks

mlabelle wrote Sep 1, 2009 at 3:29 PM

@the skipster,

Well obviously, one dependency is to have the PowerShell runtime installed:
http://www.microsoft.com/windowsserver2003/technologies/management/powershell/default.mspx

The solution also needs Visual Studio 2008 SDK, because it's actually a plug'in to Visual Studio:
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=59ec6ec3-4273-48a3-ba25-dc925a45584d

And finally, the solution uses WIX as its setup and deployment project.
http://wix.sourceforge.net/downloadv3.html

With all this, you should be able to make it work.
I'm trying to, as I write this comment, because I have the same problem.

wrote Jan 28, 2010 at 12:58 PM

wrote Feb 13, 2013 at 6:16 PM